Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Actually require the gem found

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@5616 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
commit 83dd1d8a034d7254b0d1314f9dc39a8e80e49fc7 1 parent 958e9a3
David Heinemeier Hansson dhh authored
Showing with 2 additions and 2 deletions.
  1. +2 −2 railties/environments/boot.rb
4 railties/environments/boot.rb
View
@@ -26,10 +26,10 @@
rails_gem = Gem.cache.search('rails', "~>#{version}.0").sort_by { |g| g.version.version }.last
if rails_gem
- require_gem "rails", "=#{version}"
+ require_gem "rails", "=#{rails_gem.version.version}"
require rails_gem.full_gem_path + '/lib/initializer'
else
- STDERR.puts %(Cannot find gem for Rails =#{version}:
+ STDERR.puts %(Cannot find gem for Rails ~>#{version}.0:
Install the missing gem with 'gem install -v=#{version} rails', or
change environment.rb to define RAILS_GEM_VERSION with your desired version.
)
Please sign in to comment.
Something went wrong with that request. Please try again.