Permalink
Browse files

Merge pull request #26362 from prathamesh-sonpatki/add-aj-bug-report-…

…templates

Added bug report templates for Active Job
  • Loading branch information...
guilleiguaran committed Sep 2, 2016
2 parents 74e75d3 + 26a2776 commit 8697ce4dba9a4faa8b31543dabf90c94cd186984
Showing with 63 additions and 0 deletions.
  1. +32 −0 guides/bug_report_templates/active_job_gem.rb
  2. +31 −0 guides/bug_report_templates/active_job_master.rb
@@ -0,0 +1,32 @@
begin
require "bundler/inline"
rescue LoadError => e
$stderr.puts "Bundler version 1.10 or later is required. Please update your Bundler"
raise e
end
gemfile(true) do
source "https://rubygems.org"
# Activate the gem you are reporting the issue against.
gem "activejob", "5.0.0"
end
require "minitest/autorun"
require "active_job"
# Ensure backward compatibility with Minitest 4
Minitest::Test = MiniTest::Unit::TestCase unless defined?(Minitest::Test)
class BuggyJob < ActiveJob::Base
def perform
puts "performed"
end
end
class BuggyJobTest < ActiveJob::TestCase
def test_stuff
assert_enqueued_with(job: BuggyJobTest) do
BuggyJobTest.perform_later
end
end
end
@@ -0,0 +1,31 @@
begin
require "bundler/inline"
rescue LoadError => e
$stderr.puts "Bundler version 1.10 or later is required. Please update your Bundler"
raise e
end
gemfile(true) do
source "https://rubygems.org"
gem "rails", github: "rails/rails"
end
require "active_job"
require "minitest/autorun"
# Ensure backward compatibility with Minitest 4
Minitest::Test = MiniTest::Unit::TestCase unless defined?(Minitest::Test)
class BuggyJob < ActiveJob::Base
def perform
puts "performed"
end
end
class BuggyJobTest < ActiveJob::TestCase
def test_stuff
assert_enqueued_with(job: BuggyJobTest) do
BuggyJobTest.perform_later
end
end
end

0 comments on commit 8697ce4

Please sign in to comment.