Permalink
Browse files

Update mocha version to 0.13.0 and change requires

  • Loading branch information...
carlosantoniodasilva committed Nov 12, 2012
1 parent d116e90 commit 871a7dbb4492f3bc427982559b66eb5140e4c8fe
View
@@ -3,7 +3,7 @@ source 'http://rubygems.org'
gemspec
gem "rake", ">= 0.8.7"
-gem "mocha", "0.10.5"
+gem 'mocha', '>= 0.13.0', :require => false
group :doc do
gem "rdoc", "~> 3.4"
@@ -4,7 +4,7 @@
require 'test/unit'
require 'stringio'
-require 'mocha'
+require 'mocha/setup'
require 'active_record'
require 'active_support/dependencies'
@@ -8,7 +8,7 @@
require 'active_support/json'
require 'active_support/ordered_hash'
require 'active_support/core_ext/hash/conversions'
-require 'mocha'
+require 'mocha/setup'
class BaseTest < Test::Unit::TestCase
def setup
@@ -109,7 +109,6 @@ def retrieve_mocha_counter(test_case, result) #:nodoc:
end
end
end
-
end
end
end
@@ -25,7 +25,7 @@
require 'test/unit'
require 'empty_bool'
-silence_warnings { require 'mocha' }
+silence_warnings { require 'mocha/setup' }
ENV['NO_RELOAD'] = '1'
require 'active_support'
@@ -1,7 +1,7 @@
require 'generators/generators_test_helper'
require 'rails/generators/rails/model/model_generator'
require 'rails/generators/test_unit/model/model_generator'
-require 'mocha'
+require 'mocha/setup'
class GeneratorsTest < Rails::Generators::TestCase
include GeneratorsTestHelper

0 comments on commit 871a7db

Please sign in to comment.