Permalink
Browse files

Merge pull request #5874 from asanghi/3-2-stable

replace ruby-debug19 with debugger on Rails 3-2 stable
  • Loading branch information...
2 parents 9a97699 + 56674db commit 89f99e81120e7ac608b71dad68bed2ace73b170e @jeremy jeremy committed Apr 17, 2012
@@ -35,4 +35,4 @@ gem 'jquery-rails'
# gem 'capistrano'
# To use debugger
-# gem 'ruby-debug19', :require => 'ruby-debug'
+# gem 'debugger'
@@ -205,7 +205,7 @@ The debugger used by Rails, +ruby-debug+, comes as a gem. To install it, just ru
$ sudo gem install ruby-debug
</shell>
-TIP: If you are using Ruby 1.9, you can install a compatible version of +ruby-debug+ by running +sudo gem install ruby-debug19+
+TIP: If you are using Ruby 1.9, you can install a compatible version of +debugger+ by running +sudo gem install debugger+
In case you want to download a particular version or get the source code, refer to the "project's page on rubyforge":http://rubyforge.org/projects/ruby-debug/.
@@ -188,7 +188,7 @@ def ruby_debugger_gemfile_entry
if RUBY_VERSION < "1.9"
"gem 'ruby-debug'"
else
- "gem 'ruby-debug19', :require => 'ruby-debug'"
+ "gem 'debugger'"
end
end
@@ -308,10 +308,10 @@ def test_inclusion_of_ruby_debug
end
end
- def test_inclusion_of_ruby_debug19_if_ruby19
+ def test_inclusion_of_debugger_if_ruby19
run_generator
assert_file "Gemfile" do |contents|
- assert_match(/gem 'ruby-debug19', :require => 'ruby-debug'/, contents) unless RUBY_VERSION < '1.9'
+ assert_match(/gem 'debugger'/, contents) unless RUBY_VERSION < '1.9'
end
end

0 comments on commit 89f99e8

Please sign in to comment.