Skip to content
Browse files

Require thor 0.15.3 onwards

  • Loading branch information...
1 parent 961cbcb commit 8c02918497dca0415de0d7a605b9015b67c623ab @josevalim josevalim committed Jun 18, 2012
Showing with 2 additions and 5 deletions.
  1. +1 −0 railties/lib/rails/generators/base.rb
  2. +1 −5 railties/railties.gemspec
View
1 railties/lib/rails/generators/base.rb
@@ -20,6 +20,7 @@ class Base < Thor::Group
include Rails::Generators::Actions
add_runtime_options!
+ strict_args_position!
# Returns the source root for this generator using default_source_root as default.
def self.source_root(path=nil)
View
6 railties/railties.gemspec
@@ -22,11 +22,7 @@ Gem::Specification.new do |s|
s.rdoc_options << '--exclude' << '.'
s.add_dependency('rake', '>= 0.8.7')
-
- # The current API of the Thor gem (0.14) will remain stable at least until Thor 2.0. Because
- # Thor is so heavily used by other gems, we will accept Thor's semver guarantee to reduce
- # the possibility of conflicts.
- s.add_dependency('thor', '>= 0.14.6', '< 2.0')
+ s.add_dependency('thor', '>= 0.15.3', '< 2.0')
s.add_dependency('rdoc', '~> 3.4')
s.add_dependency('activesupport', version)
s.add_dependency('actionpack', version)

0 comments on commit 8c02918

Please sign in to comment.
Something went wrong with that request. Please try again.