Browse files

Use gem versions of sass-rails and coffee-rails.

  • Loading branch information...
1 parent 1bfed9e commit 8de96949e9d3d8f0902486df343ad88401c028fd @josevalim josevalim committed Dec 17, 2011
Showing with 26 additions and 10 deletions.
  1. +26 −10 railties/lib/rails/generators/app_base.rb
View
36 railties/lib/rails/generators/app_base.rb
@@ -194,16 +194,32 @@ def ruby_debugger_gemfile_entry
def assets_gemfile_entry
return if options[:skip_sprockets]
- <<-GEMFILE.strip_heredoc.gsub(/^[ \t]*$/, '')
- # Gems used only for assets and not required
- # in production environments by default.
- group :assets do
- gem 'sass-rails', :git => 'git://github.com/rails/sass-rails.git'
- gem 'coffee-rails', :git => 'git://github.com/rails/coffee-rails.git'
- #{"gem 'therubyrhino'\n" if defined?(JRUBY_VERSION)}
- gem 'uglifier', '>= 1.0.3'
- end
- GEMFILE
+
+ gemfile = if options.dev? || options.edge?
+ <<-GEMFILE
+ # Gems used only for assets and not required
+ # in production environments by default.
+ group :assets do
+ gem 'sass-rails', :git => 'git://github.com/rails/sass-rails.git'
+ gem 'coffee-rails', :git => 'git://github.com/rails/coffee-rails.git'
+ #{"gem 'therubyrhino'\n" if defined?(JRUBY_VERSION)}
+ gem 'uglifier', '>= 1.0.3'
+ end
+ GEMFILE
+ else
+ <<-GEMFILE
+ # Gems used only for assets and not required
+ # in production environments by default.
+ group :assets do
+ gem 'sass-rails', '~> 3.2.0'
+ gem 'coffee-rails', '~> 3.2.0'
+ #{"gem 'therubyrhino'\n" if defined?(JRUBY_VERSION)}
+ gem 'uglifier', '>= 1.0.3'
+ end
+ GEMFILE
+ end
+
+ gemfile.strip_heredoc.gsub(/^[ \t]*$/, '')
end
def javascript_gemfile_entry

0 comments on commit 8de9694

Please sign in to comment.