Permalink
Browse files

allow people to set a local .Gemfile so that things like ruby-debug a…

…re not required for regular development
  • Loading branch information...
1 parent a099116 commit 8fedb5fd96c1f32c918e8745228e43a37da9e1e0 @tenderlove tenderlove committed Nov 17, 2011
Showing with 3 additions and 6 deletions.
  1. +1 −0 .gitignore
  2. +2 −6 Gemfile
View
@@ -1,6 +1,7 @@
pkg
.bundle
Gemfile.lock
+.Gemfile
debug.log
doc/rdoc
activemodel/doc
View
@@ -27,14 +27,11 @@ gem "memcache-client", ">= 1.8.5"
platforms :mri_18 do
gem "system_timer"
- gem "ruby-debug", ">= 0.10.3" unless ENV['TRAVIS']
gem "json"
end
-platforms :mri_19 do
- # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
- gem "ruby-debug19", :require => "ruby-debug" unless RUBY_VERSION > "1.9.2" || ENV['TRAVIS']
-end
+# Add your own local bundler stuff
+instance_eval File.read ".Gemfile" if File.exists? ".Gemfile"
platforms :mri do
group :test do
@@ -61,7 +58,6 @@ platforms :ruby do
end
platforms :jruby do
- gem "ruby-debug", ">= 0.10.3"
gem "json"
gem "activerecord-jdbcsqlite3-adapter", ">= 1.2.0"

1 comment on commit 8fedb5f

Owner

guilleiguaran commented on 8fedb5f Nov 18, 2011

❤️

Please sign in to comment.