Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

[PATCH] remove geminstaller dependency from ci build

  • Loading branch information...
commit 90ab1a6a4d0ed9ac18488c27fda42163a143f287 1 parent d74b5e4
Carl Lerche authored
Showing with 5 additions and 14 deletions.
  1. +5 −6 ci/ci_build.rb
  2. +0 −8 ci/geminstaller.yml
View
11 ci/ci_build.rb
@@ -14,13 +14,12 @@ def rake(*tasks)
puts "[CruiseControl] Rails build"
build_results = {}
-# Requires gem home and path to be writeable and/or overridden to be ~/.gem,
-# Will enable when RubyGems supports this properly (in a coming release)
-# build_results[:geminstaller] = system 'geminstaller --exceptions'
+# Install rubygems-update, so 'gem update --system' in cruise_config.rb auto-installs it on next build.
+# This is how you can auto-update rubygems without logging in to CI system
+build_results[:geminstaller] = system "sudo gem install rubygems-update -v 1.3.5 --no-ri --no-rdoc"
-# for now, use the no-passwd sudoers approach (documented in ci_setup_notes.txt)
-# A security hole, but there is nothing valuable on rails CI box anyway.
-build_results[:geminstaller] = system "sudo geminstaller --config=#{root_dir}/ci/geminstaller.yml --exceptions"
+# Install required version of bundler.
+build_results[:geminstaller] = system "sudo gem install bundler -v 0.9.0.pre3 --prerelease --no-ri --no-rdoc"
cd root_dir do
puts
View
8 ci/geminstaller.yml
@@ -1,8 +0,0 @@
----
-gems:
-- name: geminstaller
- version: >= 0.4.3
-- name: rubygems-update
- version: >= 1.3.5
-- name: bundler
- version: >= 0.9.0.pre
Please sign in to comment.
Something went wrong with that request. Please try again.