Permalink
Browse files

Fix reference to StringQuestioneer (renamed to StringInquirer) in 2.2…

… release notes
  • Loading branch information...
1 parent f7b6e70 commit 92320985fab909adc39ea927f095421ae16a5d27 @ffmike ffmike committed Oct 27, 2008
@@ -953,6 +953,11 @@ <h3 id="_other_active_support_changes">9.4. Other Active Support Changes</h3>
The included TzInfo library has been upgraded to version 0.3.11.
</p>
</li>
+<li>
+<p>
+<tt>ActiveSuport::StringInquirer</tt> gives you a pretty way to test for equality in strings: <tt>ActiveSupport::StringInquirer.new("abc").abc? &#8658; true</tt>
+</p>
+</li>
</ul></div>
</div>
<h2 id="_railties">10. Railties</h2>
@@ -1051,7 +1056,7 @@ <h3 id="_other_railties_changes">10.2. Other Railties Changes</h3>
</li>
<li>
<p>
-Wrapped <tt>Rails.env</tt> in <tt>StringQuestioneer</tt> so you can do <tt>Rails.env.development?</tt>
+Wrapped <tt>Rails.env</tt> in <tt>StringInquirer</tt> so you can do <tt>Rails.env.development?</tt>
</p>
</li>
<li>
@@ -353,6 +353,7 @@ Lead Contributor: link:http://workingwithrails.com/person/5830-daniel-schierbeck
* +Inflector#parameterize+ produces a URL-ready version of its input, for use in +to_param+.
* +Time#advance+ recognizes fractional days and weeks, so you can do +1.7.weeks.ago+, +1.5.hours.since+, and so on.
* The included TzInfo library has been upgraded to version 0.3.11.
+* +ActiveSuport::StringInquirer+ gives you a pretty way to test for equality in strings: +ActiveSupport::StringInquirer.new("abc").abc? => true+
== Railties
@@ -384,7 +385,7 @@ You can unpack or install a single gem by specifying +GEM=_gem_name_+ on the com
* +script/console+ now supports a +--debugger+ option
* Instructions for setting up a continuous integration server to build Rails itself are included in the Rails source
* +rake notes:custom ANNOTATION=MYFLAG+ lets you list out custom annotations.
-* Wrapped +Rails.env+ in +StringQuestioneer+ so you can do +Rails.env.development?+
+* Wrapped +Rails.env+ in +StringInquirer+ so you can do +Rails.env.development?+
* +script/generate+ works without deprecation warnings when RubyGems 1.3.0 is present
== Deprecated

0 comments on commit 9232098

Please sign in to comment.