Permalink
Browse files

The rails gem doesn't have a lib directory.

  • Loading branch information...
pixeltrix committed Jul 4, 2011
1 parent cee27be commit 92c852f7e229e27ed7a1c1e8d3ec001f14983b63
Showing with 3 additions and 2 deletions.
  1. +3 −2 rails.gemspec
View
@@ -14,8 +14,9 @@ Gem::Specification.new do |s|
s.email = 'david@loudthinking.com'
s.homepage = 'http://www.rubyonrails.org'
- s.bindir = 'bin'
- s.executables = ['rails']
+ s.bindir = 'bin'
+ s.executables = ['rails']
+ s.require_paths = []
s.add_dependency('activesupport', version)
s.add_dependency('actionpack', version)

3 comments on commit 92c852f

@dmathieu

This comment has been minimized.

Show comment
Hide comment
@dmathieu

dmathieu Jul 4, 2011

Contributor

This gives me a warning when installing the gem :

Using rails (3.1.0.rc4) from git://github.com/rails/rails.git (at 3-1-stable) 
rails at /Users/dmathieu/.rvm/gems/ruby-1.9.2-p180@dmathieu/bundler/gems/rails-92c852f7e229 did not have a valid gemspec.
This prevents bundler from installing bins or native extensions, but that may not affect its functionality.
The validation message from Rubygems was:
  specification must have at least one require_path
Contributor

dmathieu replied Jul 4, 2011

This gives me a warning when installing the gem :

Using rails (3.1.0.rc4) from git://github.com/rails/rails.git (at 3-1-stable) 
rails at /Users/dmathieu/.rvm/gems/ruby-1.9.2-p180@dmathieu/bundler/gems/rails-92c852f7e229 did not have a valid gemspec.
This prevents bundler from installing bins or native extensions, but that may not affect its functionality.
The validation message from Rubygems was:
  specification must have at least one require_path
@pixeltrix

This comment has been minimized.

Show comment
Hide comment
@pixeltrix

pixeltrix Jul 4, 2011

Member

Which version of rubygems?

Member

pixeltrix replied Jul 4, 2011

Which version of rubygems?

@dmathieu

This comment has been minimized.

Show comment
Hide comment
@dmathieu

dmathieu Jul 4, 2011

Contributor

1.6.2. But I just upgraded and it does the same with 1.8.5

Contributor

dmathieu replied Jul 4, 2011

1.6.2. But I just upgraded and it does the same with 1.8.5

Please sign in to comment.