Skip to content
Browse files

Add Gemfile dependency for require_relative on mri18. This is a depen…

…dency of linecache which is a dependency of ruby-debug. However, the latest release of linecache (0.45) omits the dependency from its gemspec, causing the build to fail. I have emailed the maintainer so we should remove this when it's fixed upstream.
  • Loading branch information...
1 parent 190677d commit 954359b9c260f0e1265237c20bb3e4834a11fb9a @jonleighton jonleighton committed
Showing with 3 additions and 0 deletions.
  1. +3 −0  Gemfile
3  Gemfile
@@ -26,6 +26,9 @@ gem "memcache-client", ">= 1.8.5"
platforms :mri_18 do
gem "system_timer"
+ # ruby-debug requires linecache which depends on require_relative but doesn't explicitly
+ # declare this in its gemspec
+ gem "require_relative"
gem "ruby-debug", ">= 0.10.3"
gem "json"

3 comments on commit 954359b


@jonleighton How about downgrading linecache instead of using require_relative ??


Instead of loading new library and using new feature with older rubies we can stick with older version of linecache right??

These are my thoughts. Want to know your thoughts for this??


No really, why are adding dependency of a library in Rails itself? shouldn't linecache specify its own dependency, rather than Rails adding stuff for it?


@arunagw I don't really see that one solution is more valid than the other. They both involve explicitly specifying a dependency of a dependency in our Gemfile. This works so I see no reason to change it.

@gnufied If you read the commit message you can see that I said I asked the maintainer of linecache to fix this so that we can remove this again. Also, this file does not specify the dependencies for the actual gems that get shipped, just the dependencies for running tests etc.

Please sign in to comment.
Something went wrong with that request. Please try again.