Skip to content
Browse files

Merge pull request #3208 from Empact/patch-1

Change rake db:schema:dump to load schema dumper extensions such as those used by foreigner and spatial_adapter
  • Loading branch information...
2 parents 3530afa + e41bd38 commit 9d349914dd22fb12fb066fb35c62d181f7a9af66 @josevalim josevalim committed
Showing with 1 addition and 1 deletion.
  1. +1 −1 activerecord/lib/active_record/railties/databases.rake
View
2 activerecord/lib/active_record/railties/databases.rake
@@ -341,7 +341,7 @@ db_namespace = namespace :db do
namespace :schema do
desc 'Create a db/schema.rb file that can be portably used against any DB supported by AR'
- task :dump => :load_config do
+ task :dump => [:environment, :load_config] do
require 'active_record/schema_dumper'
filename = ENV['SCHEMA'] || "#{Rails.root}/db/schema.rb"
File.open(filename, "w:utf-8") do |file|

0 comments on commit 9d34991

Please sign in to comment.
Something went wrong with that request. Please try again.