Permalink
Browse files

Update tzinfo dependency to ~> 1.1

Include the tzinfo-data in the generated Gemfile on Windows.
  • Loading branch information...
1 parent 281f488 commit 9d664b18df7a81b75e45bb99858f920de040e9fb @sferik sferik committed Nov 10, 2013
@@ -22,7 +22,7 @@ Gem::Specification.new do |s|
s.add_dependency('i18n', '~> 0.6', '>= 0.6.4')
s.add_dependency 'json', '~> 1.7'
- s.add_dependency 'tzinfo', '~> 0.3.37'
+ s.add_dependency 'tzinfo', '~> 1.1'
s.add_dependency 'minitest', '~> 5.0'
s.add_dependency 'thread_safe','~> 0.1'
end
@@ -28,3 +28,8 @@ source 'https://rubygems.org'
# Use debugger
# gem 'debugger', group: [:development, :test]
<% end -%>
+
+<% if RUBY_PLATFORM.match(/bccwin|cygwin|emx|mingw|mswin|wince/) -%>
+# Windows does not include zoneinfo files, so bundle the tzinfo-data gem
+gem 'tzinfo-data', platforms: [:mingw, :mswin]
+<% end -%>

0 comments on commit 9d664b1

Please sign in to comment.