Permalink
Browse files

Prefer Ruby 2.0; require 1.9.3+

  • Loading branch information...
jeremy committed Feb 10, 2013
1 parent 56f5188 commit a0380e808d3dbd2462df17f5d3b7fcd8bd812496
@@ -3,7 +3,7 @@ Ruby on Rails 4.0 Release Notes
Highlights in Rails 4.0:
* Ruby 1.9.3 only
* Ruby 2.0 preferred; 1.9.3+ required
* Strong Parameters
* Turbolinks
* Russian Doll Caching
@@ -21,7 +21,7 @@ application from scratch. It does not assume that you have any prior experience
with Rails. However, to get the most out of it, you need to have some
prerequisites installed:
* The [Ruby](http://www.ruby-lang.org/en/downloads) language version 1.9.3 or higher
* The [Ruby](http://www.ruby-lang.org/en/downloads) language version 1.9.3 or newer
* The [RubyGems](http://rubygems.org/) packaging system
* To learn more about RubyGems, please read the [RubyGems User Guide](http://docs.rubygems.org/read/book/1)
* A working installation of the [SQLite3 Database](http://www.sqlite.org)
@@ -84,7 +84,7 @@ current version of Ruby installed:
```bash
$ ruby -v
ruby 1.9.3p327
ruby 1.9.3p385
```
To install Rails, use the `gem install` command provided by RubyGems:
@@ -16,11 +16,11 @@ The best way to be sure that your application still works after upgrading is to
Rails generally stays close to the latest released Ruby version when it's released:
* Rails 3 and above requires Ruby 1.8.7 or higher. Support for all of the previous Ruby versions has been dropped officially and you should upgrade as early as possible.
* Rails 3.2.x will be the last branch to support Ruby 1.8.7.
* Rails 4 will support only Ruby 1.9.3.
* Rails 3 and above require Ruby 1.8.7 or higher. Support for all of the previous Ruby versions has been dropped officially. You should upgrade as early as possible.
* Rails 3.2.x is the last branch to support Ruby 1.8.7.
* Rails 4 prefers Ruby 2.0 and requires 1.9.3 or newer.
TIP: Ruby 1.8.7 p248 and p249 have marshaling bugs that crash Rails. Ruby Enterprise Edition has these fixed since the release of 1.8.7-2010.02. On the 1.9 front, Ruby 1.9.1 is not usable because it outright segfaults, so if you want to use 1.9.x, jump on to 1.9.2 or 1.9.3 for smooth sailing.
TIP: Ruby 1.8.7 p248 and p249 have marshaling bugs that crash Rails. Ruby Enterprise Edition has these fixed since the release of 1.8.7-2010.02. On the 1.9 front, Ruby 1.9.1 is not usable because it outright segfaults, so if you want to use 1.9.x, jump straight to 1.9.3 for smooth sailing.
Upgrading from Rails 3.2 to Rails 4.0
-------------------------------------
@@ -2,12 +2,12 @@
desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
abort <<-end_message
Rails 4 requires Ruby 1.9.3+.
Rails 4 prefers to run on Ruby 2.0.

This comment has been minimized.

Show comment
Hide comment
@tenderlove

tenderlove Feb 12, 2013

Member

❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️

@tenderlove

tenderlove Feb 12, 2013

Member

❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️❤️

This comment has been minimized.

Show comment
Hide comment
@sikachu

sikachu Feb 12, 2013

Member

👍 great news.

@sikachu

sikachu Feb 12, 2013

Member

👍 great news.

This comment has been minimized.

Show comment
Hide comment
@steveklabnik

steveklabnik Feb 12, 2013

Member

👏 🎊

@steveklabnik

steveklabnik Feb 12, 2013

Member

👏 🎊

This comment has been minimized.

Show comment
Hide comment
@fcofdez

fcofdez Feb 12, 2013

Great news! :)

@fcofdez

fcofdez Feb 12, 2013

Great news! :)

This comment has been minimized.

Show comment
Hide comment
@Randuin

Randuin Feb 12, 2013

living on the edge

@Randuin

Randuin Feb 12, 2013

living on the edge

This comment has been minimized.

Show comment
Hide comment
@chrisb

chrisb Feb 12, 2013

👍 sweet!

@chrisb

This comment has been minimized.

Show comment
Hide comment
@calebthompson

calebthompson Feb 12, 2013

Contributor

Yesssss.

@calebthompson

calebthompson Feb 12, 2013

Contributor

Yesssss.

This comment has been minimized.

Show comment
Hide comment
@parndt

parndt Feb 12, 2013

Contributor

Most Interesting

@parndt

This comment has been minimized.

Show comment
Hide comment
@mdespuits

mdespuits Feb 12, 2013

Contributor

👏 Yay!

@mdespuits

mdespuits Feb 12, 2013

Contributor

👏 Yay!

You're running
#{desc}
Please upgrade to continue.
Please upgrade to Ruby 1.9.3 or newer to continue.
end_message
end

3 comments on commit a0380e8

@gtcarlos

This comment has been minimized.

Show comment
Hide comment
@gtcarlos

gtcarlos replied Feb 14, 2013

Nice :-D

@zolzaya

This comment has been minimized.

Show comment
Hide comment
@zolzaya

zolzaya Feb 14, 2013

Contributor

👍

Contributor

zolzaya replied Feb 14, 2013

👍

@atulveer

This comment has been minimized.

Show comment
Hide comment
@atulveer

atulveer replied Aug 13, 2013

👍

Please sign in to comment.