Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Remove stuff that was deprecated in 2-1-stable

  • Loading branch information...
commit a5cdb7a813515fa0cbee23101d2f911b4017ed90 1 parent 6fae0a0
@lifo lifo authored
View
26 actionpack/lib/action_controller/caching/fragments.rb
@@ -26,32 +26,6 @@ module Caching
#
# expire_fragment(:controller => "topics", :action => "list", :action_suffix => "all_topics")
module Fragments
- def self.included(base) #:nodoc:
- base.class_eval do
- class << self
- def fragment_cache_store=(store_option) #:nodoc:
- ActiveSupport::Deprecation.warn('The fragment_cache_store= method is now use cache_store=')
- self.cache_store = store_option
- end
-
- def fragment_cache_store #:nodoc:
- ActiveSupport::Deprecation.warn('The fragment_cache_store method is now use cache_store')
- cache_store
- end
- end
-
- def fragment_cache_store=(store_option) #:nodoc:
- ActiveSupport::Deprecation.warn('The fragment_cache_store= method is now use cache_store=')
- self.cache_store = store_option
- end
-
- def fragment_cache_store #:nodoc:
- ActiveSupport::Deprecation.warn('The fragment_cache_store method is now use cache_store')
- cache_store
- end
- end
- end
-
# Given a key (as described in <tt>expire_fragment</tt>), returns a key suitable for use in reading,
# writing, or expiring a cached fragment. If the key is a hash, the generated key is the return
# value of url_for on that hash (without the protocol). All keys are prefixed with "views/" and uses
View
16 actionpack/lib/action_view/base.rb
@@ -172,18 +172,6 @@ class << self
delegate :logger, :to => 'ActionController::Base'
end
- def self.cache_template_loading=(*args)
- ActiveSupport::Deprecation.warn(
- "config.action_view.cache_template_loading option has been deprecated" +
- "and has no effect. Please remove it from your config files.", caller)
- end
-
- def self.cache_template_extensions=(*args)
- ActiveSupport::Deprecation.warn(
- "config.action_view.cache_template_extensions option has been" +
- "deprecated and has no effect. Please remove it from your config files.", caller)
- end
-
# Templates that are exempt from layouts
@@exempt_from_layout = Set.new([/\.rjs$/])
@@ -259,10 +247,6 @@ def render(options = {}, local_assigns = {}, &block) #:nodoc:
if options[:layout]
_render_with_layout(options, local_assigns, &block)
elsif options[:file]
- if options[:use_full_path]
- ActiveSupport::Deprecation.warn("use_full_path option has been deprecated and has no affect.", caller)
- end
-
_pick_template(options[:file]).render_template(self, options[:locals])
elsif options[:partial]
render_partial(options)
View
4 activesupport/lib/active_support.rb
@@ -59,7 +59,3 @@
require 'active_support/rescuable'
I18n.load_path << File.dirname(__FILE__) + '/active_support/locale/en-US.yml'
-
-Inflector = ActiveSupport::Deprecation::DeprecatedConstantProxy.new('Inflector', 'ActiveSupport::Inflector')
-Dependencies = ActiveSupport::Deprecation::DeprecatedConstantProxy.new('Dependencies', 'ActiveSupport::Dependencies')
-TimeZone = ActiveSupport::Deprecation::DeprecatedConstantProxy.new('TimeZone', 'ActiveSupport::TimeZone')
View
1  activesupport/test/dependencies_test.rb
@@ -279,7 +279,6 @@ def test_qualified_const_defined
assert ActiveSupport::Dependencies.qualified_const_defined?("Object")
assert ActiveSupport::Dependencies.qualified_const_defined?("::Object")
assert ActiveSupport::Dependencies.qualified_const_defined?("::Object::Kernel")
- assert ActiveSupport::Dependencies.qualified_const_defined?("::Object::Dependencies")
assert ActiveSupport::Dependencies.qualified_const_defined?("::Test::Unit::TestCase")
end

0 comments on commit a5cdb7a

Please sign in to comment.
Something went wrong with that request. Please try again.