Permalink
Browse files

Moved dependencies from Gemfile to gemspec to eliminate redundant dec…

…larations.
  • Loading branch information...
1 parent d9b59c3 commit a74e4736f95befa7a22c208019bf11a155ff7543 @dgeb dgeb committed Jul 27, 2011
@@ -17,4 +17,15 @@ Gem::Specification.new do |s|
<% unless options.skip_test_unit? -%>
s.test_files = Dir["test/**/*"]
<% end -%>
+
+ # If your gem is dependent on a specific version (or higher) of Rails:
+ <%= '# ' if options.dev? || options.edge? -%>s.add_dependency "rails", ">= <%= Rails::VERSION::STRING %>"
+
+<% unless options[:skip_javascript] || !full? -%>
+ # If your gem contains any <%= "#{options[:javascript]}-specific" %> javascript:
+ # s.add_dependency "<%= "#{options[:javascript]}-rails" %>"
+
+<% end -%>
+ # Declare development-specific dependencies:
+ s.add_development_dependency "<%= gem_for_database %>"
end
@@ -1,14 +1,20 @@
source "http://rubygems.org"
-<%= rails_gemfile_entry -%>
+# Declare your gem's dependencies in <%= name %>.gemspec.
+# Bundler will treat runtime dependencies like base dependencies, and
+# development dependencies will be added by default to the :development group.
+gemspec
-<% if full? -%>
-<%= database_gemfile_entry -%>
-<% end -%>
+# Declare any dependencies that are still in development here instead of in
+# your gemspec. These might include edge Rails or gems from your path or
+# Git. Remember to move these dependencies to your gemspec before releasing
+# your gem to rubygems.org.
-<% if mountable? -%>
-<%= javascript_gemfile_entry -%>
-<% end -%>
+<% if options.dev? || options.edge? -%>
+# Your gem is dependent on dev or edge Rails. Once you can lock this
+# dependency down to a specific version, move it to your gemspec.
+<%= rails_gemfile_entry -%>
+<% end -%>
# To use debugger
# <%= ruby_debugger_gemfile_entry %>

0 comments on commit a74e473

Please sign in to comment.