Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Update Redcarpet to 3.1.2

This version fixes an API breakage between 3.0 and 3.1 ; the header
method's arity should not have changed.

[ci skip]
  • Loading branch information...
commit ad3628b3116553cc02c354fb5c552ec103de52dd 1 parent 567aa54
@robin850 robin850 authored
View
2  Gemfile
@@ -25,7 +25,7 @@ gem 'uglifier', '>= 1.3.0', require: false
group :doc do
gem 'sdoc', '~> 0.4.0'
- gem 'redcarpet', '~> 3.1.0', platforms: :ruby
+ gem 'redcarpet', '~> 3.1.2', platforms: :ruby
gem 'w3c_validators'
gem 'kindlerb'
end
View
4 guides/rails_guides.rb
@@ -24,11 +24,11 @@ def bundler?
require 'redcarpet'
rescue LoadError
# This can happen if doc:guides is executed in an application.
- $stderr.puts('Generating guides requires Redcarpet 3.1.0+.')
+ $stderr.puts('Generating guides requires Redcarpet 3.1.2+.')
$stderr.puts(<<ERROR) if bundler?
Please add
- gem 'redcarpet', '~> 3.1.0'
+ gem 'redcarpet', '~> 3.1.2'
to the Gemfile, run
View
2  guides/rails_guides/markdown/renderer.rb
@@ -15,7 +15,7 @@ def block_code(code, language)
HTML
end
- def header(text, header_level, anchor)
+ def header(text, header_level)
# Always increase the heading level by, so we can use h1, h2 heading in the document
header_level += 1
Please sign in to comment.
Something went wrong with that request. Please try again.