Skip to content
Browse files

Use require_library_or_gem 'fcgi' in script/server

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@2920 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent fa0a597 commit aec5273f41af4f7c4cfa335b904b6fce6499bbda @sstephenson sstephenson committed Nov 7, 2005
Showing with 3 additions and 1 deletion.
  1. +2 −0 railties/CHANGELOG
  2. +1 −1 railties/lib/commands/server.rb
View
2 railties/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Use require_library_or_gem 'fcgi' in script/server [Sam Stephenson]
+
* Added default lighttpd config in config/lighttpd.conf and added a default runner for lighttpd in script/server (works like script/server, but using lighttpd and FastCGI). It will use lighttpd if available, otherwise WEBrick. You can force either or using 'script/server lighttpd' or 'script/server webrick' [DHH]
* New configuration option config.plugin_paths which may be a single path like the default 'vendor/plugins' or an array of paths: ['vendor/plugins', 'lib/plugins']. [Jeremy Kemper]
View
2 railties/lib/commands/server.rb
@@ -1,7 +1,7 @@
require 'active_support'
begin
- require 'fcgi'
+ require_library_or_gem 'fcgi'
rescue Exception
# FCGI not available
end

0 comments on commit aec5273

Please sign in to comment.
Something went wrong with that request. Please try again.