Skip to content
Browse files

Bump mysql gem version to the newly 2.9.0, fix build.

  • Loading branch information...
1 parent 89a00f3 commit af43e719ac45ea3f8589b07d4d1d43d8bf0a31e9 @carlosantoniodasilva carlosantoniodasilva committed
Showing with 2 additions and 2 deletions.
  1. +1 −1 Gemfile
  2. +1 −1 activerecord/lib/active_record/connection_adapters/mysql_adapter.rb
View
2 Gemfile
@@ -51,7 +51,7 @@ platforms :ruby do
group :db do
gem 'pg', '>= 0.11.0'
- gem 'mysql', '>= 2.8.1'
+ gem 'mysql', '>= 2.9.0'
gem 'mysql2', '>= 0.3.10'
end
end
View
2 activerecord/lib/active_record/connection_adapters/mysql_adapter.rb
@@ -2,7 +2,7 @@
require 'active_record/connection_adapters/statement_pool'
require 'active_support/core_ext/hash/keys'
-gem 'mysql', '~> 2.8.1'
+gem 'mysql', '~> 2.9.0'
require 'mysql'
class Mysql

2 comments on commit af43e71

@pixeltrix
Ruby on Rails member

Do we want to make this change in 3-2-stable since we're trying to get it to run on Ruby 2.0? The mysql 2.8.x gem uses the deprecated Config instead of RbConfig. Maybe we should use gem 'mysql', '>= 2.8.1' on 3-2-stable as we probably don't want to force people to update.

@carlosantoniodasilva
Ruby on Rails member

I thought that it'd be ok to have ~> 2.9.0, perhaps we can have only ~> 2.8?

Please sign in to comment.
Something went wrong with that request. Please try again.