Permalink
Browse files

stop circular require warnings

  • Loading branch information...
1 parent bac5da3 commit b907271b4baae8966e8cd133931e5bc9c557219e @tenderlove tenderlove committed Aug 24, 2011
@@ -1,5 +1,4 @@
require "action_dispatch"
-require "rails"
module ActionDispatch
class Railtie < Rails::Railtie
@@ -1,5 +1,4 @@
require "active_support"
-require "rails"
require "active_support/file_update_checker"
require "active_support/core_ext/array/wrap"
@@ -1,5 +1,4 @@
require "active_support"
-require "rails"
require "active_support/i18n_railtie"
module ActiveSupport

1 comment on commit b907271

Without 'require "rails"' I get the exception :
'uninitialized constant I18n::Rails' in i18n_railtie.rb:6:in `module:I18n'
during 'rake test' run.

Please sign in to comment.