Skip to content
Browse files

Relax mail gem constraint from ~> 2.5.4 to ~> 2.5, >= 2.5.4

This allows Rails users to install mail 2.6 which relaxes
the mime-types dependency, which is a big win for a lot of people.

Previously, the mail gem restricted mime-types to ~> 1.16
but now it has expanded to [">= 1.16", "< 3"]

And the mime-types maintainer will also be checking that
2.x releases don't break mail.

See mikel/mail#713
https://rubygems.org/gems/mail/versions/2.6.0
  • Loading branch information...
1 parent 4bcf902 commit bb0890d0569a924c14bd57ba5fda280d5a181c30 @bf4 bf4 committed Jun 3, 2014
Showing with 1 addition and 1 deletion.
  1. +1 −1 actionmailer/actionmailer.gemspec
View
2 actionmailer/actionmailer.gemspec
@@ -22,5 +22,5 @@ Gem::Specification.new do |s|
s.add_dependency 'actionpack', version
s.add_dependency 'actionview', version
- s.add_dependency 'mail', '~> 2.5.4'
+ s.add_dependency 'mail', ['~> 2.5', '>= 2.5.4']
end

0 comments on commit bb0890d

Please sign in to comment.
Something went wrong with that request. Please try again.