Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Relax i18n requirement.

  • Loading branch information...
commit bd944798a5732fcd59e6d0b1140ac15203f9b2be 1 parent 19ff18e
@josevalim josevalim authored
View
2  actionpack/actionpack.gemspec
@@ -22,7 +22,7 @@ Gem::Specification.new do |s|
s.add_dependency('activesupport', version)
s.add_dependency('activemodel', version)
s.add_dependency('builder', '~> 2.1.2')
- s.add_dependency('i18n', '~> 0.4.1')
+ s.add_dependency('i18n', '~> 0.4')
s.add_dependency('rack', '~> 1.2.1')
s.add_dependency('rack-test', '~> 0.5.6')
s.add_dependency('rack-mount', '~> 0.6.13')
View
2  activemodel/activemodel.gemspec
@@ -21,5 +21,5 @@ Gem::Specification.new do |s|
s.add_dependency('activesupport', version)
s.add_dependency('builder', '~> 2.1.2')
- s.add_dependency('i18n', '~> 0.4.1')
+ s.add_dependency('i18n', '~> 0.4')
end

4 comments on commit bd94479

@svenfuchs

YAY :)

@cameronyule

This change results in i18n 0.5 being installed as a dependency. The mail gem, which is a dependency of ActionMailer, will then refuse to install as it has a soft dependency on i18n 0.4.1. This means a clean install of Rails 3.0.3 won't work without manually installing the i18n 0.4.x gem.

@svenfuchs

Cameron, you're right. We believe this change is what we want though.

We've (again) asked Mike to relax the dependency in Mail as well, see mikel/mail#155 (comment)

You might want to comment over there, too :)

@spastorino
Owner

Mikel released mail 2.2.11 so everything should work now.

Please sign in to comment.
Something went wrong with that request. Please try again.