Skip to content
This repository
Browse code

More accurate JRuby gem requirements

Signed-off-by: Santiago Pastorino <santiago@wyeworks.com>
Signed-off-by: José Valim <jose.valim@gmail.com>
  • Loading branch information...
commit c0db7840fe6dfd9aef8120b24e05f7e6f400d382 1 parent aacf258
Nick Sieger authored May 19, 2010 josevalim committed May 20, 2010

Showing 1 changed file with 15 additions and 5 deletions. Show diff stats Hide diff stats

  1. 20  Gemfile
20  Gemfile
@@ -17,15 +17,25 @@ if mri || RUBY_ENGINE == "rbx"
17 17
   gem 'yajl-ruby'
18 18
   gem "nokogiri", ">= 1.4.0"
19 19
 elsif RUBY_ENGINE == "jruby"
20  
-  gem "jruby-debug"
  20
+  gem "ruby-debug"
  21
+  gem "jruby-openssl"
21 22
 end
22 23
 
23 24
 # AR
24  
-gem "sqlite3-ruby", "= 1.3.0.beta.2", :require => 'sqlite3'
  25
+if mri || RUBY_ENGINE == "rbx"
  26
+  gem "sqlite3-ruby", "= 1.3.0.beta.2", :require => 'sqlite3'
  27
+
  28
+  group :db do
  29
+    gem "pg", ">= 0.9.0"
  30
+    gem "mysql", ">= 2.8.1"
  31
+  end
  32
+elsif RUBY_ENGINE == "jruby"
  33
+  gem "activerecord-jdbcsqlite3-adapter"
25 34
 
26  
-group :db do
27  
-  gem "pg", ">= 0.9.0"
28  
-  gem "mysql", ">= 2.8.1"
  35
+  group :db do
  36
+    gem "activerecord-jdbcmysql-adapter"
  37
+    gem "activerecord-jdbcpostgresql-adapter"
  38
+  end
29 39
 end
30 40
 
31 41
 # AP

0 notes on commit c0db784

Please sign in to comment.
Something went wrong with that request. Please try again.