Skip to content
Browse files

If using Ruby 1.8.5, pull in call_stack so breakpointer works again.

If using Ruby 1.8.5 and call_stack is not installed, give warnings and
instructions.


git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@5380 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent c5dcec7 commit c1c96d55d754e6de1572e35bc9bc68cc896655bf Scott Barron committed Nov 1, 2006
Showing with 15 additions and 1 deletion.
  1. +15 −1 railties/lib/breakpoint.rb
View
16 railties/lib/breakpoint.rb
@@ -16,7 +16,21 @@
# license please contact me.
require 'irb'
-require 'binding_of_caller'
+if RUBY_VERSION == '1.8.5'
+ begin
+ require 'rubygems'
+ require 'breakpoint185'
+ rescue LoadError
+ puts 'WARNING: breakpoints will not work with Ruby 1.8.5 without the call_stack gem.'
+ puts ' gem install call_stack or see http://eigenclass.org/hiki.rb?call_stack'
+ def Binding.of_caller(&block)
+ raise 'Breakpoint requires the call_stack gem with Ruby 1.8.5.'
+ return
+ end
+ end
+else
+ require 'binding_of_caller'
+end
require 'drb'
require 'drb/acl'

0 comments on commit c1c96d5

Please sign in to comment.
Something went wrong with that request. Please try again.