Permalink
Browse files

ActionPack test helpers need to activate rack gem

  • Loading branch information...
1 parent ad49895 commit c5f6e038daf2221ddd5a7534e68f4158d84a5975 @josh josh committed Sep 1, 2009
@@ -11,11 +11,12 @@
ENV['new_base'] = "true"
$stderr.puts "Running old tests on new_base"
+require 'rubygems'
+gem "rack", "~> 1.0.0"
+gem "rack-test", "~> 0.4.2"
+
require 'test/unit'
require 'active_support'
-
-gem "rack-test"
-
require 'active_support/test_case'
require 'action_controller'
require 'fixture_template'
@@ -2,6 +2,10 @@
$:.unshift(File.dirname(__FILE__) + '/../../../activesupport/lib')
$:.unshift(File.dirname(__FILE__) + '/../lib')
+require 'rubygems'
+gem "rack", "~> 1.0.0"
+gem "rack-test", "~> 0.4.2"
+
require 'test/unit'
require 'active_support'
require 'active_support/test_case'
@@ -8,6 +8,9 @@
$:.unshift(File.dirname(__FILE__) + '/fixtures/alternate_helpers')
require 'rubygems'
+gem "rack", "~> 1.0.0"
+gem "rack-test", "~> 0.4.2"
+
require 'yaml'
require 'stringio'
require 'test/unit'

0 comments on commit c5f6e03

Please sign in to comment.