Skip to content
Browse files

All libraries should link against the independent active support

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@625 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent dc3d6eb commit ca175ed7c9b357fdb40e7f3e31cd0283354fd54c @dhh dhh committed Feb 15, 2005
View
10 actionpack/lib/action_controller.rb
@@ -24,18 +24,10 @@
$:.unshift(File.dirname(__FILE__))
begin
- require 'active_support/core_ext'
- require 'active_support/clean_logger'
- require 'active_support/misc'
- require 'active_support/dependencies'
+ require 'active_support'
rescue LoadError
require 'rubygems'
require_gem 'activesupport'
-
- require 'active_support/core_ext'
- require 'active_support/clean_logger'
- require 'active_support/misc'
- require 'active_support/dependencies'
end
require 'action_controller/base'
View
10 activerecord/lib/active_record.rb
@@ -25,18 +25,10 @@
$:.unshift(File.dirname(__FILE__))
begin
- require 'active_support/core_ext'
- require 'active_support/clean_logger'
- require 'active_support/misc'
- require 'active_support/dependencies'
+ require 'active_support'
rescue LoadError
require 'rubygems'
require_gem 'activesupport'
-
- require 'active_support/core_ext'
- require 'active_support/clean_logger'
- require 'active_support/misc'
- require 'active_support/dependencies'
end
require 'active_record/base'
View
1 railties/environments/shared.rb
@@ -30,6 +30,7 @@
# Require Rails libraries.
+require 'active_support'
require 'active_record'
require 'action_controller'
require 'action_mailer'
View
1 railties/environments/shared_for_gem.rb
@@ -25,6 +25,7 @@
# Require Rails gems.
require 'rubygems'
+require_gem 'activesupport'
require_gem 'activerecord'
require_gem 'actionpack'
require_gem 'actionmailer'
View
2 railties/lib/dispatcher.rb
@@ -24,7 +24,7 @@
require 'breakpoint'
class Dispatcher
- class <<self
+ class << self
def dispatch(cgi = CGI.new, session_options = ActionController::CgiRequest::DEFAULT_SESSION_OPTIONS)
begin
prepare_application
View
3 railties/lib/rails_generator.rb
@@ -23,8 +23,7 @@
$:.unshift(File.dirname(__FILE__))
-require 'active_support/core_ext'
-
+require 'active_support'
require 'rails_generator/base'
require 'rails_generator/lookup'
View
2 railties/lib/rails_generator/base.rb
@@ -1,5 +1,3 @@
-require 'active_support/class_attribute_accessors'
-require 'active_support/inflector'
require File.dirname(__FILE__) + '/options'
require File.dirname(__FILE__) + '/manifest'
require File.dirname(__FILE__) + '/spec'
View
1 railties/lib/rails_generator/options.rb
@@ -1,5 +1,4 @@
require 'optparse'
-require 'active_support/class_inheritable_attributes'
module Rails
module Generator

0 comments on commit ca175ed

Please sign in to comment.
Something went wrong with that request. Please try again.