Permalink
Browse files

Update the Bundler snippet for 0.9.15 and above

  • Loading branch information...
1 parent 86defed commit ca378659bcaa41f5bd231b6792bf50c941e7fd12 @indirect indirect committed with wycats Apr 12, 2010
Showing with 7 additions and 15 deletions.
  1. +2 −2 rails.gemspec
  2. +5 −13 railties/lib/rails/generators/rails/app/templates/config/boot.rb
View
@@ -14,7 +14,7 @@ Gem::Specification.new do |s|
s.email = 'david@loudthinking.com'
s.homepage = 'http://www.rubyonrails.org'
s.rubyforge_project = 'rails'
-
+
s.files = []
s.require_path = []
@@ -24,5 +24,5 @@ Gem::Specification.new do |s|
s.add_dependency('activeresource', version)
s.add_dependency('actionmailer', version)
s.add_dependency('railties', version)
- s.add_dependency('bundler', '>= 0.9.14')
+ s.add_dependency('bundler', '>= 0.9.19')
end
@@ -1,14 +1,6 @@
-# Use locked gems if present.
-begin
- require File.expand_path('../../.bundle/environment', __FILE__)
-
-rescue LoadError
- # Otherwise, use RubyGems.
- require 'rubygems'
-
- # And set up the gems listed in the Gemfile.
- if File.exist?(File.expand_path('../../Gemfile', __FILE__))
- require 'bundler'
- Bundler.setup
- end
+require 'rubygems'
+# Set up gems listed in the Gemfile.
+if File.exist?(File.expand_path('../../Gemfile', __FILE__))
+ require 'bundler'
+ Bundler.setup
end

0 comments on commit ca37865

Please sign in to comment.