Permalink
Browse files

Lock Uglifier to below 4.0

Uglifier 4.0.1 doesn't work without Sprockets 3.7.1. Since 4.2 isn't
really getting updates we should try to at least maintain a green build.

Fixes the following errors:

Build ref: https://travis-ci.org/rails/rails/jobs/313152105#L777
Build ref: https://travis-ci.org/rails/rails/jobs/313152105#L772
  • Loading branch information...
eileencodes committed Dec 7, 2017
1 parent b8935e4 commit ca565684bb7ea65a1b4fb17b3529b980b05bf081
Showing with 2 additions and 2 deletions.
  1. +1 −1 Gemfile
  2. +1 −1 Gemfile.lock
View
@@ -32,7 +32,7 @@ gem 'bcrypt', '~> 3.1.10', require: false
# This needs to be with require false to avoid
# it being automatically loaded by sprockets
gem 'uglifier', '>= 1.3.0', require: false
gem 'uglifier', '>= 1.3.0', "< 4.0.0", require: false
# mime-types 3 only support ruby >= 2
gem 'mime-types', '< 3', require: false
View
@@ -295,7 +295,7 @@ DEPENDENCIES
stackprof
sucker_punch (< 2.0)
turbolinks
uglifier (>= 1.3.0)
uglifier (>= 1.3.0, < 4.0.0)
w3c_validators
BUNDLED WITH

0 comments on commit ca56568

Please sign in to comment.