Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Mention the removal of attr_accessible and attr_protected in the upgr…

…ading guide

Point to the Protected Attributes gem to those who want a smoothly
upgrade path before to change to use Strong Parameters.

[ci skip]
  • Loading branch information...
commit d1c5f879b0f8fbb991c8948eaba02fe2c69156bb 1 parent d5ec8ef
@rafaelfranca rafaelfranca authored
Showing with 2 additions and 0 deletions.
  1. +2 −0  guides/source/upgrading_ruby_on_rails.md
View
2  guides/source/upgrading_ruby_on_rails.md
@@ -45,6 +45,8 @@ Rails 4.0 no longer supports loading plugins from `vendor/plugins`. You must rep
* Rails 4.0 has changed `serialized_attributes` and `attr_readonly` to class methods only. Now you shouldn't use instance methods, it's deprecated. You must change them, e.g. `self.serialized_attributes` to `self.class.serialized_attributes`.
+* Rails 4.0 has removed `attr_accessible` and `attr_protected` feature in favor of Strong Parameters. You can use the [Protected Attributes gem](https://github.com/rails/protected_attributes) to a smoothly upgrade path.
+
### Active Model
* Rails 4.0 has changed how errors attach with the `ActiveModel::Validations::ConfirmationValidator`. Now when confirmation validations fail the error will be attached to `:#{attribute}_confirmation` instead of `attribute`.
Please sign in to comment.
Something went wrong with that request. Please try again.