Skip to content
Browse files

Alter prior change to use require_dependency instead of require_or_lo…

…ad. Causes ApplicationController to be reloaded again. Closes #6587.

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@5471 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent 089d3ec commit d3100ec85500b970f94819a749f071eeb74dc206 @seckar seckar committed Nov 9, 2006
Showing with 3 additions and 1 deletion.
  1. +2 −0 railties/CHANGELOG
  2. +1 −1 railties/lib/dispatcher.rb
View
2 railties/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Alter prior change to use require_dependency instead of require_or_load. Causes ApplicationController to be reloaded again. Closes #6587. [Nicholas Seckar]
+
* Rake: use absolute paths to load lib and vendor tasks so they may be run outside of RAILS_ROOT. #6584 [jchris]
* Remove temporary crutch to help ApplicationController be unloaded. Closes #6496. [Nicholas Seckar]
View
2 railties/lib/dispatcher.rb
@@ -101,7 +101,7 @@ def prepare_application
end
prepare_breakpoint
- Dependencies.require_or_load('application') unless Object.const_defined?(:ApplicationController)
+ require_dependency 'application' unless Object.const_defined?(:ApplicationController)
ActiveRecord::Base.verify_active_connections! if defined?(ActiveRecord)
run_preparation_callbacks
end

0 comments on commit d3100ec

Please sign in to comment.
Something went wrong with that request. Please try again.