Skip to content
This repository
Browse code

require "rubygems" is obsolete in Ruby 1.9.3

  • Loading branch information...
commit d8c194968469f3afe39412818505ac94f78e386d 1 parent aeac0bf
Kornelius Kalnbach authored May 13, 2012
2  guides/source/action_view_overview.textile
Source Rendered
@@ -59,7 +59,6 @@ Now we'll create a simple "Hello World" application that uses the +titleize+ met
59 59
 *hello_world.rb:*
60 60
 
61 61
 <ruby>
62  
-require 'rubygems'
63 62
 require 'active_support/core_ext/string/inflections'
64 63
 require 'rack'
65 64
 
@@ -94,7 +93,6 @@ Now we'll create the same "Hello World" application in Sinatra.
94 93
 *hello_world.rb:*
95 94
 
96 95
 <ruby>
97  
-require 'rubygems'
98 96
 require 'action_view'
99 97
 require 'sinatra'
100 98
 
1  guides/source/active_model_basics.textile
Source Rendered
@@ -95,7 +95,6 @@ h4. Dirty
95 95
 An object becomes dirty when an object is gone through one or more changes to its attributes and not yet saved. This gives the ability to check whether an object has been changed or not. It also has attribute based accessor methods. Lets consider a Person class with attributes first_name and last_name
96 96
 
97 97
 <ruby>
98  
-require 'rubygems'
99 98
 require 'active_model'
100 99
 
101 100
 class Person
1  load_paths.rb
... ...
@@ -1,4 +1,3 @@
1 1
 # bust gem prelude
2  
-require 'rubygems' unless defined? Gem
3 2
 require 'bundler'
4 3
 Bundler.setup
1  railties/lib/rails/commands/application.rb
@@ -19,7 +19,6 @@
19 19
   end
20 20
 end
21 21
 
22  
-require 'rubygems' if ARGV.include?("--dev")
23 22
 require 'rails/generators'
24 23
 require 'rails/generators/rails/app/app_generator'
25 24
 
2  railties/lib/rails/commands/plugin_new.rb
... ...
@@ -1,5 +1,3 @@
1  
-require 'rubygems' if ARGV.include?("--dev")
2  
-
3 1
 if ARGV.first != "new"
4 2
   ARGV[0] = "--help"
5 3
 else
2  railties/lib/rails/generators/rails/app/templates/config/boot.rb
... ...
@@ -1,5 +1,3 @@
1  
-require 'rubygems'
2  
-
3 1
 # Set up gems listed in the Gemfile.
4 2
 ENV['BUNDLE_GEMFILE'] ||= File.expand_path('../../Gemfile', __FILE__)
5 3
 
1  railties/lib/rails/generators/rails/plugin_new/templates/rails/boot.rb
... ...
@@ -1,4 +1,3 @@
1  
-require 'rubygems'
2 1
 gemfile = File.expand_path('../../../../Gemfile', __FILE__)
3 2
 
4 3
 if File.exist?(gemfile)
1  railties/lib/rails/generators/test_unit/plugin/templates/test_helper.rb
... ...
@@ -1,3 +1,2 @@
1  
-require 'rubygems'
2 1
 require 'minitest/autorun'
3 2
 require 'active_support'
1  tools/profile
@@ -7,7 +7,6 @@ ENV['NO_RELOAD'] ||= '1'
7 7
 ENV['RAILS_ENV'] ||= 'development'
8 8
 
9 9
 GC.enable_stats
10  
-require 'rubygems'
11 10
 Gem.source_index
12 11
 require 'benchmark'
13 12
 

0 notes on commit d8c1949

Please sign in to comment.
Something went wrong with that request. Please try again.