Permalink
Browse files

Fix Bug: disable_referential_integrity doesn't work for postgres 9.0.1

  • Loading branch information...
1 parent 206e48e commit d9ac62c91466e40b557d27c4d712f86759d63a4b @matthewrudy matthewrudy committed Nov 20, 2010
Showing with 1 addition and 4 deletions.
  1. +1 −4 activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb
@@ -404,10 +404,7 @@ def session_auth=(user)
# REFERENTIAL INTEGRITY ====================================
def supports_disable_referential_integrity?() #:nodoc:
- version = query("SHOW server_version")[0][0].split('.')
- version[0].to_i >= 8 && version[1].to_i >= 1
- rescue
- return false
+ postgresql_version >= 80100
end
def disable_referential_integrity #:nodoc:

0 comments on commit d9ac62c

Please sign in to comment.