Permalink
Browse files

Clarify vendor/plugins deprecation warning

  • Loading branch information...
1 parent d22592a commit d9e0c4a0132ef71e9f6901440ed261037263dbc3 @jeremy jeremy committed Jan 4, 2012
Showing with 1 addition and 1 deletion.
  1. +1 −1 railties/lib/rails/plugin.rb
@@ -53,7 +53,7 @@ def railtie_name
end
def initialize(root)
- ActiveSupport::Deprecation.warn "Plugins are deprecated and will be removed in Rails 4.0. Use gems instead or bundler with path or git dependencies."
+ ActiveSupport::Deprecation.warn "You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb."
@name = File.basename(root).to_sym
config.root = root
end

0 comments on commit d9e0c4a

Please sign in to comment.