Permalink
Browse files

Updating to use Mail v2.3.0

  Need to move the require of mail in test/abstract_unit to be after active support
  to make sure we use ActiveSupport multibyte handlers, otherwise, Mail will load its
  internal multibyte compat
  • Loading branch information...
1 parent b73c84e commit dd44626c7f2015c61d83a1be1265e664e87419f6 @mikel mikel committed Apr 26, 2011
Showing with 6 additions and 6 deletions.
  1. +1 −1 actionmailer/actionmailer.gemspec
  2. +5 −5 actionmailer/test/abstract_unit.rb
View
2 actionmailer/actionmailer.gemspec
@@ -18,5 +18,5 @@ Gem::Specification.new do |s|
s.requirements << 'none'
s.add_dependency('actionpack', version)
- s.add_dependency('mail', '~> 2.2.16')
+ s.add_dependency('mail', '~> 2.3.0')
end
View
10 actionmailer/test/abstract_unit.rb
@@ -23,18 +23,18 @@
end
end
-silence_warnings do
- # These external dependencies have warnings :/
- require 'mail'
-end
-
lib = File.expand_path("#{File.dirname(__FILE__)}/../lib")
$:.unshift(lib) unless $:.include?('lib') || $:.include?(lib)
require 'test/unit'
require 'action_mailer'
require 'action_mailer/test_case'
+silence_warnings do
+ # These external dependencies have warnings :/
+ require 'mail'
+end
+
# Show backtraces for deprecated behavior for quicker cleanup.
ActiveSupport::Deprecation.debug = true

0 comments on commit dd44626

Please sign in to comment.