Permalink
Browse files

Merge pull request #28055 from robertomiranda/patch-3

Use Puma 3.7
  • Loading branch information...
guilleiguaran committed Feb 21, 2017
2 parents c1d57d7 + bd163bd commit de4c9186d8bd03b1957dec6b7c84bfbeef9c31aa
Showing with 2 additions and 2 deletions.
  1. +1 −1 railties/lib/rails/generators/app_base.rb
  2. +1 −1 railties/test/generators/app_generator_test.rb
@@ -193,7 +193,7 @@ def database_gemfile_entry # :doc:
def webserver_gemfile_entry # :doc:
return [] if options[:skip_puma]
comment = "Use Puma as the app server"
GemfileEntry.new("puma", "~> 3.0", comment)
GemfileEntry.new("puma", "~> 3.7", comment)
end
def include_all_railties? # :doc:
@@ -340,7 +340,7 @@ def test_generator_without_skips
def test_generator_defaults_to_puma_version
run_generator [destination_root]
assert_gem "puma", "'~> 3.0'"
assert_gem "puma", "'~> 3.7'"
end
def test_generator_if_skip_puma_is_given

0 comments on commit de4c918

Please sign in to comment.