Skip to content
Browse files

Revert "Use sass compressor as the default CSS compressor"

This reverts commit 3eef1c7.
The css compressor should be set in sass-rails plugin. Check
rails/sass-rails@339529f
for the fix.
  • Loading branch information...
1 parent 3eef1c7 commit ebe9590def08b5bf23372b0e5d88bd210864f2de @guilleiguaran guilleiguaran committed Feb 25, 2013
View
2 railties/lib/rails/generators/rails/app/templates/config/environments/production.rb.tt
@@ -25,7 +25,7 @@
<%- unless options.skip_sprockets? -%>
# Compress JavaScripts and CSS.
config.assets.js_compressor = :uglifier
- config.assets.css_compressor = :sass
+ # config.assets.css_compressor = :sass
# Whether to fallback to assets pipeline if a precompiled asset is missed.
config.assets.compile = false

3 comments on commit ebe9590

@teddyzetterlund

If this is being done by the sass-rails plugin, why is it only commented out in this file instead of removed?

@guilleiguaran
Ruby on Rails member

@teddyzetterlund this is left just as a guide for users that want to switch to another compressor

@teddyzetterlund

@guilleiguaran Makes sense, though I think it kind of implies that it's not being done already (by default) by sass-rails. Maybe it's worth adding some clarity somehow?

Please sign in to comment.
Something went wrong with that request. Please try again.