Permalink
Browse files

Merge pull request #18209 from claudiob/bump-to-2-2

Require Ruby 2.2 for Rails 5.0
  • Loading branch information...
guilleiguaran committed Dec 28, 2014
2 parents e7e1b68 + d3b098b commit edaab4dbe80ac9ae705be05f7d9e20f942e057ab
View
@@ -20,7 +20,7 @@ env:
- "GEM=ar:postgresql"
- "GEM=aj:integration"
rvm:
- 2.1
- 2.2
- ruby-head
- rbx-2
- jruby
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Email composition, delivery, and receiving framework (part of Rails).'
s.description = 'Email on Rails. Compose, deliver, receive, and test emails using the familiar controller/view pattern. First-class support for multipart email and attachments.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Web-flow and rendering framework putting the VC in MVC (part of Rails).'
s.description = 'Web apps on Rails. Simple, battle-tested conventions for building and testing MVC web applications. Works with any Rack-compatible server.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Rendering framework putting the V in MVC (part of Rails).'
s.description = 'Simple, battle-tested conventions and helpers for building web pages.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Job framework with pluggable queues.'
s.description = 'Declare job classes that can be run by a variety of queueing backends.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'A toolkit for building modeling frameworks (part of Rails).'
s.description = 'A toolkit for building modeling frameworks like Active Record. Rich support for attributes, callbacks, validations, serialization, internationalization, and testing.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Object-relational mapper framework (part of Rails).'
s.description = 'Databases on Rails. Build a persistent domain model by mapping database tables to Ruby classes. Strong conventions for associations, validations, aggregations, migrations, and testing come baked-in.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework.'
s.description = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'
@@ -1,13 +1,13 @@
if RUBY_VERSION < '2.1.0'
if RUBY_VERSION < '2.2.0'
desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
abort <<-end_message
Rails 5 requires to run on Ruby 2.1 or newer.
Rails 5 requires to run on Ruby 2.2.0 or newer.
You're running
#{desc}
Please upgrade to Ruby 2.1.0 or newer to continue.
Please upgrade to Ruby 2.2.0 or newer to continue.
end_message
end
@@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Tools for creating, working with, and running Rails applications.'
s.description = 'Rails internals: application bootup, plugins, generators, and rake tasks.'
s.required_ruby_version = '>= 2.1.0'
s.required_ruby_version = '>= 2.2.0'
s.license = 'MIT'

0 comments on commit edaab4d

Please sign in to comment.