Permalink
Browse files

Fix a few more 1.9 bugs. Rack 1.0.1 is required for 1.9 compliance bu…

…t not release, so bundling 1.0.1 from git
  • Loading branch information...
1 parent c44d560 commit ef70ad5538c4ce02c4d31ef01a8db6b55c837571 @wycats wycats committed Oct 16, 2009
Showing with 2 additions and 2 deletions.
  1. +1 −1 actionpack/Gemfile
  2. +1 −1 actionpack/test/dispatch/test_request_test.rb
View
@@ -2,7 +2,7 @@ rails_root = Pathname.new(File.dirname(__FILE__)).join("..")
Gem.sources.each { |uri| source uri }
-gem "rack", "~> 1.0.0"
+gem "rack", "1.0.1", :git => "git://github.com/rack/rack.git", :branch => "rack-1.0"
gem "rack-test", "~> 0.5.0"
gem "activesupport", "3.0.pre", :vendored_at => rails_root.join("activesupport")
gem "activemodel", "3.0.pre", :vendored_at => rails_root.join("activemodel")
@@ -18,7 +18,7 @@ class TestRequestTest < ActiveSupport::TestCase
assert_equal "0.0.0.0", env.delete("REMOTE_ADDR")
assert_equal "Rails Testing", env.delete("HTTP_USER_AGENT")
- assert_equal [0, 1], env.delete("rack.version")
+ assert_equal [1, 0], env.delete("rack.version")
assert_equal "", env.delete("rack.input").string
assert_kind_of StringIO, env.delete("rack.errors")
assert_equal true, env.delete("rack.multithread")

0 comments on commit ef70ad5

Please sign in to comment.