Skip to content
Browse files

Fix tests in railties

Since `bundle install` was fixed in `rails plugin new`, it
now requires `rails 4.0.0.beta` version in filesystem when
running tests. Instead of providing it, we can run tested
command with `--dev` option, to use rails from the local
directory.
  • Loading branch information...
1 parent 5904295 commit f3482a9fb17ba33e51d9ae096036f5f712078220 @drogus drogus committed
Showing with 1 addition and 1 deletion.
  1. +1 −1 railties/test/generators/plugin_new_generator_test.rb
View
2 railties/test/generators/plugin_new_generator_test.rb
@@ -99,7 +99,7 @@ def test_ensure_that_database_option_is_passed_to_app_generator
end
def test_generation_runs_bundle_install_with_full_and_mountable
- result = run_generator [destination_root, "--mountable", "--full"]
+ result = run_generator [destination_root, "--mountable", "--full", "--dev"]
assert_file "#{destination_root}/Gemfile.lock" do |contents|
assert_match(/bukkits/, contents)
end

0 comments on commit f3482a9

Please sign in to comment.
Something went wrong with that request. Please try again.