Permalink
Browse files

If using svn 1.1.x and no REVISION is specified, give an error message

to the user suggesting they use REVISION.

References #4450
Closes #4569


git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@4154 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent c66b44e commit fb8428fe0dbb53d1793ecc9cb623f96418566029 Scott Barron committed Apr 4, 2006
Showing with 9 additions and 2 deletions.
  1. +9 −2 railties/lib/tasks/framework.rake
@@ -35,12 +35,19 @@ namespace :rails do
desc "Lock to latest Edge Rails or a specific revision with REVISION=X (ex: REVISION=4021) or a tag with TAG=Y (ex: TAG=rel_1-1-0)"
task :edge do
$verbose = false
- `svn --version` rescue nil
+ svn_version = `svn --version -q` rescue nil
unless !$?.nil? && $?.success?
$stderr.puts "ERROR: Must have subversion (svn) available in the PATH to lock this application to Edge Rails"
exit 1
end
-
+
+ major, minor, sub = svn_version.strip.split '.'
+ if ENV['REVISION'].nil? && major.to_i == 1 && minor.to_i < 2
+ puts "The --limit option is not available in your version of svn."
+ puts "Please try this syntax: rake rails:freeze:edge REVISION=4145"
+ exit 1
+ end
+
rm_rf "vendor/rails"
mkdir_p "vendor/rails"

0 comments on commit fb8428f

Please sign in to comment.