Sanitize helper method not working properly with html comments. #14104

Closed
krunal opened this Issue Feb 18, 2014 · 5 comments

Comments

Projects
None yet
6 participants
@krunal

krunal commented Feb 18, 2014

Following is the example of sanitize method.

>> helper.sanitize("<!-- Script Start --><p>krunal test2</p>")
=> "&lt;!-- Script Start --><p>krunal test2</p>"

We can see in the above code that "html comment" tag get changed in output.

@pftg

This comment has been minimized.

Show comment
Hide comment
@pftg

pftg Feb 19, 2014

Contributor
Contributor

pftg commented Feb 19, 2014

@tomkadwill

This comment has been minimized.

Show comment
Hide comment
@tomkadwill

tomkadwill Apr 26, 2014

Contributor

cc @krunal @pftg @rafaelfranca I've tested this against #11218 and sanitize correctly ignores HTML comments. Can we close this issue?

Contributor

tomkadwill commented Apr 26, 2014

cc @krunal @pftg @rafaelfranca I've tested this against #11218 and sanitize correctly ignores HTML comments. Can we close this issue?

@laurocaetano

This comment has been minimized.

Show comment
Hide comment
@laurocaetano

laurocaetano Apr 26, 2014

Contributor

Hi @tomkadwill!

I think we should wait until #11218 gets merged.

Contributor

laurocaetano commented Apr 26, 2014

Hi @tomkadwill!

I think we should wait until #11218 gets merged.

@rails-bot rails-bot added the stale label Aug 19, 2014

@rails-bot

This comment has been minimized.

Show comment
Hide comment
@rails-bot

rails-bot Aug 19, 2014

This issue has been automatically marked as stale because it has not been commented on for at least
three months.

The resources of the Rails team are limited, and so we are asking for your help.

If you can still reproduce this error on the 4-1-stable, 4-0-stable branches or on master,
please reply with all of the information you have about it in order to keep the issue open.

Thank you for all your contributions.

This issue has been automatically marked as stale because it has not been commented on for at least
three months.

The resources of the Rails team are limited, and so we are asking for your help.

If you can still reproduce this error on the 4-1-stable, 4-0-stable branches or on master,
please reply with all of the information you have about it in order to keep the issue open.

Thank you for all your contributions.

@rafaelfranca

This comment has been minimized.

Show comment
Hide comment
@rafaelfranca

rafaelfranca Nov 19, 2014

Member

It should be fixed with 4.2. If not please let us know.

Member

rafaelfranca commented Nov 19, 2014

It should be fixed with 4.2. If not please let us know.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment