jruby can not install rails-3.0.8.rc3 #1416

Closed
mkristian opened this Issue May 31, 2011 · 2 comments

Projects

None yet

2 participants

@mkristian

jruby -S gem install rails --pre
ERROR: While executing gem ... (ArgumentError)
undefined class/module YAML::Syck::DefaultKey

jruby-1.6.x especially with jruby-complete.jar which comes with a packed rubygems.

PLEASE if possible use a rubygems to build the rails gems which works out of the box with jruby. jruby users are a bit troubled recently with rubygems bugs (jruby related - maybe).

also I know I school which use central ldap for authentication and central NFS-server for the home directories and all workstations are exactly the same and can use only debian/ubuntu packages. i.e. they can not upgrade rubygems => they can not use rails-3.0.8.rc3

@parndt
Contributor
parndt commented May 31, 2011

Did you try rc4? I believe it fixes the issue

@mkristian

indeed
java -jar jruby-complete-1.6.2.jar -S gem install rails --pre --version 3.0.8.rc4
does work.
but
java -jar jruby-complete-1.6.2.jar -S gem install rails --pre --version 3.0.8.rc3
and
java -jar jruby-complete-1.6.2.jar -S gem install rails --pre
do not work. I guess the later is due the yaml in rc3 gem.

I guess fir the released version things are on save side.

@mkristian mkristian closed this May 31, 2011
@jake3030 jake3030 pushed a commit to jake3030/rails that referenced this issue Jun 28, 2011
@Manfred @lifo Manfred + lifo Free MySQL::Result objects after a call to execute [#1416 state:resol…
…ved]

No freeing Result objects causes the MySQL driver to free result sets
at undefined times, this can lead to erratic performance in your
application.

Signed-off-by: Frederick Cheung <frederick.cheung@gmail.com>
8326b95
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment