Warnings while installing rails 3.1-rc4 #1958

Closed
ddebernardy opened this Issue Jul 4, 2011 · 9 comments

Projects

None yet

3 participants

@ddebernardy

Ruby 1.9.2. Log file:


DB:~/ruby $ sudo gem install rails --pre
(...)
20 gems installed
Installing ri documentation for activesupport-3.1.0.rc4...
Installing ri documentation for builder-3.0.0...
unable to convert "\xF1" from ASCII-8BIT to UTF-8 for README, skipping
unable to convert "\xF1" from ASCII-8BIT to UTF-8 for README.rdoc, skipping
(...)
Installing ri documentation for rails-3.1.0.rc4...
file 'lib' not found
Installing RDoc documentation for activesupport-3.1.0.rc4...
Installing RDoc documentation for builder-3.0.0...
unable to convert "\xF1" from ASCII-8BIT to UTF-8 for README, skipping
unable to convert "\xF1" from ASCII-8BIT to UTF-8 for README.rdoc, skipping
(...)
Installing RDoc documentation for rails-3.1.0.rc4...
file 'lib' not found

I realize the first is builder related. But the `file 'lib' not found seems to be rails related.

@pixeltrix
Ruby on Rails member

Are you running ruby with -Ku? This may be being set via the RUBYOPT environment variable.

@ddebernardy

Not that I'm aware of. I'm kind of new to ruby, too, so please bear with me. :-P

DB:~ $ ruby --version
ruby 1.9.2p180 (2011-02-18 revision 30909) [x86_64-darwin10]
DB:~ $ echo $RUBYOPT

(...)
>> pp $:
["/opt/local/lib/ruby1.9/site_ruby/1.9.1",
 "/opt/local/lib/ruby1.9/site_ruby/1.9.1/x86_64-darwin10",
 "/opt/local/lib/ruby1.9/site_ruby",
 "/opt/local/lib/ruby1.9/vendor_ruby/1.9.1",
 "/opt/local/lib/ruby1.9/vendor_ruby/1.9.1/x86_64-darwin10",
 "/opt/local/lib/ruby1.9/vendor_ruby",
 "/opt/local/lib/ruby1.9/1.9.1",
 "/opt/local/lib/ruby1.9/1.9.1/x86_64-darwin10"]

@pixeltrix
Ruby on Rails member

Is this a self-compiled version of ruby or from a package manager like macports?

@ddebernardy

It was installed using macports like so:

port install ruby19 +nosuffix
@pixeltrix pixeltrix was assigned Jul 4, 2011
@pixeltrix
Ruby on Rails member

Okay it looks as though the rails.gemspec doesn't clear the Gem::Specification#require_paths setting.

@pixeltrix
Ruby on Rails member

The builder errors are due to bad/no encoding on the files.

@ddebernardy

Re the builder errors, should I report it to them directly, or are you contributing to that project as well?

@pixeltrix
Ruby on Rails member

Please report them directly.

@pixeltrix pixeltrix closed this in e7fc5d1 Jul 4, 2011
@martinploeger martinploeger pushed a commit to martinploeger/rails that referenced this issue Jul 4, 2011
@pixeltrix pixeltrix Revert "The rails gem doesn't have a lib directory - closes #1958."
RubyGems requires at least one require_path.

This reverts commit e7fc5d1.
718542b
@pburleson

Since this has been reverted, I'd like to see this issue reopened. Although mine issue is with rails 3.0.10. I get the lib file not found. I've done everything I can find from Googling, and nothing appears to fix this issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment