Fix sprockets warnings #2598

Closed
josh opened this Issue Aug 20, 2011 · 7 comments

5 participants

@josh
Ruby on Rails member

Just released sprockets beta 14 and forget I deprecated some stuff that I need to update in Rails.

Everything should still be working, just need to change some things around in Rails to shut up the warnings.

@josh josh was assigned Aug 20, 2011
@josh josh added a commit that closed this issue Aug 21, 2011
@josh josh Fix sprockets warnings
Fixes #2598
63d3809
@josh josh closed this in 63d3809 Aug 21, 2011
@erwin16

so , for people using Rails 3.1.rc6, nothing to do just wait for 3.1 release end of month ? right ?

@josh
Ruby on Rails member

You can use rails/3-1-stable or use an older version of sprockets.

@arunagw arunagw pushed a commit to arunagw/rails that referenced this issue Aug 22, 2011
@josh josh Fix sprockets warnings
Fixes #2598
d7bef0a
@dynamic50

whats the story on this? still getting Sprockets::Environment#static_root is deprecated with RC6. Cheers! Jason

@erwin16

even w Rails3.1-stable ? .. I am moving to it now

@dynamic50

Haven't tried 3.1-stable let me know how it goes for you :-)

@kirs

Was it fixed in rc8?

@JangoSteve
Ruby on Rails member

This issue appears to have been fixed in rc8 for me. If I use anything older than rc8, I have to downgrade to sprockets 2.0.0.beta.15 at the latest.

@ttosch ttosch pushed a commit that referenced this issue Jan 19, 2015
@josh josh Fix sprockets warnings
Fixes #2598
360e03d
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment