Cannot install rails: ERROR: While executing gem ... (NoMethodError) - undefined method `call' for nil:NilClas #4565

Closed
minaguib opened this Issue Jan 20, 2012 · 4 comments

Comments

Projects
None yet
2 participants
@minaguib

This happens on a brand new clean virtual machine with just ruby-ee 1.8.7 and rubygems 1.3.7

# gem install -V rails
GET http://rubygems.org/latest_specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/latest_specs.4.8.gz
200 OK
GET http://rubygems.org/specs.4.8.gz
302 Found
GET http://production.s3.rubygems.org/specs.4.8.gz
200 OK
Installing gem activemodel-3.2.0
ERROR:  While executing gem ... (NoMethodError)
    undefined method `call' for nil:NilClass

Installing other gems works:

# gem install rake
Successfully installed rake-0.9.2.2
1 gem installed
Installing ri documentation for rake-0.9.2.2...
Installing RDoc documentation for rake-0.9.2.2...
@guilleiguaran

This comment has been minimized.

Show comment
Hide comment
@guilleiguaran

guilleiguaran Jan 20, 2012

Member

Try upgrading rubygems to 1.8.15

Member

guilleiguaran commented Jan 20, 2012

Try upgrading rubygems to 1.8.15

@minaguib

This comment has been minimized.

Show comment
Hide comment
@minaguib

minaguib Jan 21, 2012

I had considered that.

Unfortunately, my distro (gentoo linux) has so far only marked version 1.3.7 in its package manager (portage) as stable.

rubygems 1.8.x are available in portage, but marked as unstable - I'm not sure yet why - whether it causes further problems/conflicts down the line if enabled on a gentoo box - or whether that's simply due to them not being tested enough yet.

Either way though, if it's a bug, it should be fixed in the activemodel packaging methinks. If it requires rubygems 1.8, it should make that a hard requirement and complain.

I had considered that.

Unfortunately, my distro (gentoo linux) has so far only marked version 1.3.7 in its package manager (portage) as stable.

rubygems 1.8.x are available in portage, but marked as unstable - I'm not sure yet why - whether it causes further problems/conflicts down the line if enabled on a gentoo box - or whether that's simply due to them not being tested enough yet.

Either way though, if it's a bug, it should be fixed in the activemodel packaging methinks. If it requires rubygems 1.8, it should make that a hard requirement and complain.

@guilleiguaran

This comment has been minimized.

Show comment
Hide comment
@guilleiguaran

guilleiguaran Jan 21, 2012

Member

This will be fixed with rails 3.2.1, you can follow the discussion about it in #4559.

Member

guilleiguaran commented Jan 21, 2012

This will be fixed with rails 3.2.1, you can follow the discussion about it in #4559.

@minaguib

This comment has been minimized.

Show comment
Hide comment
@minaguib

minaguib Jan 21, 2012

Cool. Thank you.

FWIW I filed a ticket on Gentoo's bugzilla for the flip side of the problem: https://bugs.gentoo.org/show_bug.cgi?id=399571

Cool. Thank you.

FWIW I filed a ticket on Gentoo's bugzilla for the flip side of the problem: https://bugs.gentoo.org/show_bug.cgi?id=399571

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment