Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Edge doc Chapter 9 does not work in Rails-4.0.0.beta1 #9921

Closed
ozpos opened this Issue · 15 comments

4 participants

@ozpos

Hi all,

The edge doc chapter 9 needs updating.

I would do so if I could find out how to get this use case to work under Rails-4.0.0.beta1

Please help this has brought my migration to rails 4 to a standstill despite several posings from myself to various forums.

John Leake

@sikachu
Collaborator

Would you mind posting the link to the edge doc you were talking about? Thanks.

@ozpos
@senny
Owner

@ozpos what guide are you talking about? Can you link to the section? In order to help you, we need to know what you were reading / doing. :smile_cat:

@ozpos
@steveklabnik
Collaborator

Great! The "edge rails doc" can mean anything on http://edgeguides.rubyonrails.org/ , which there are a lot of things! They're not ordered, so "Chapter 9" doesn't make a lot of sense.

What specifically does not work with the form helpers part? As far as I know, it should be up to date.

@senny
Owner

@ozpos what exactly in that chapter did not work? Did you get a stack-trace? Did nothing happen at all? Can you publish a sample application illustrating the problem on github?

@steveklabnik the problem might be that strong_params is not mentioned at all in that section. Let's wait for his confirmation but I can add a small description for strong params and link to the relevant AC docs.

@ozpos
@ozpos
@senny
Owner

@ozpos great! I will update the guide to mention strong parameters. In the mean time you can check out the following resources, which should explain your use case:

please still post the app to github, this will help me updating the guides.

@ozpos

Hi senny, All I seem to do these days is apologize for my incompetency. My dev environment is RubyMine and although when I test my github account within the VCS settings RM connects fine. When I do a push it fails with authentication failure.

I am a newbe git.

@senny
Owner

@ozpos no worries :heart:. Github has a great help section to get your environment up and running. I don't use RubyMine so I can't help you very much but maybe these FAQ from Jetbrains help: http://www.jetbrains.com/ruby/webhelp/using-github-integration.html

Let me know if it worked. I'm off for today but will update the docs tomorrow.

@steveklabnik
Collaborator

Don't worry about being a newbie!

@ozpos

Nearly a day later and I have managed to get a repo up to github:-
https://github.com/ozpos/urps2
I cannot seem to get the Rails 3.2 version up yet:-
https://github.com/ozpos/urps1

@ozpos
@senny
Owner

@ozpos I documented the correct usage of strong parameters #9947. Let me know if this helps.

@senny senny closed this in 1a5c3f4
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.