Also should supports PostgreSQL 9.1 about extensions. #10504

Merged
merged 2 commits into from May 15, 2013

Projects

None yet

3 participants

@kennyj
Contributor
kennyj commented May 7, 2013

In edge rails with PostgrelSQL 9.1.x, PostgreSQLAdapter#supports_extensions? always returns false .

But I think that PostgreSQL 9.1.x supports extension feature well (including hstore and uuid-ossp).

@ghost
ghost commented May 10, 2013

👍 I ran into this issue today. The result is that the schema dumper removes the enable_extension lines from db/schema.rb every time i run rake db:migrate. Postgres 9.1 most certainly supports extensions: http://www.postgresql.org/docs/9.1/static/sql-createextension.html

Screenshot of my db/schema.rb diff:
http://note.io/149Jpuj

@mikeycgto

Can confirm this issue here as well. Same story as @BigNerdRanchDan.

@rafaelfranca
Member

@kennyj could you add a CHANGELOG entry?

@kennyj
Contributor
kennyj commented May 15, 2013

@rafaelfranca I've updated it.

I think we should backport this PR to 4-0-stable too. wdyt?

@rafaelfranca rafaelfranca merged commit f22dbc6 into rails:master May 15, 2013
@kennyj kennyj deleted the kennyj:support_pg_91 branch May 16, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment