New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rails 6 requires Ruby 2.4.1+ #32034

Merged
merged 1 commit into from Feb 17, 2018

Conversation

Projects
None yet
3 participants
@jeremy
Member

jeremy commented Feb 17, 2018

References #32028

Skipping over 2.4.0 to sidestep the "symbol_from_string".to_sym.dup bug.

/cc @mtsmfm @matthewd

@jeremy jeremy requested a review from rafaelfranca Feb 17, 2018

Rails 6 requires Ruby 2.4.1+
Skipping over 2.4.0 to sidestep the `"symbol_from_string".to_sym.dup` bug.

References #32028

@jeremy jeremy merged commit d4eb0dc into rails:master Feb 17, 2018

2 checks passed

codeclimate All good!
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details

@jeremy jeremy deleted the jeremy:drop-ruby-2.3 branch Feb 17, 2018

koic added a commit to koic/oracle-enhanced that referenced this pull request Feb 17, 2018

@koic koic referenced this pull request Feb 17, 2018

Merged

Rails 6 requires Ruby 2.4.1+ #1657

- 2.3.6
- 2.4.3
- 2.5.0
- 2.4

This comment has been minimized.

@matthewd

matthewd Feb 18, 2018

Member

@jeremy this means 2.4.1... is that what you meant?

@matthewd

matthewd Feb 18, 2018

Member

@jeremy this means 2.4.1... is that what you meant?

This comment has been minimized.

@jeremy

jeremy Feb 18, 2018

Member

Nope. That's disappointing.

@jeremy

jeremy Feb 18, 2018

Member

Nope. That's disappointing.

This comment has been minimized.

@jeremy

jeremy Feb 18, 2018

Member

Flipped back to major.minor.tiny @ 6b3acf1 🙃

@jeremy

jeremy Feb 18, 2018

Member

Flipped back to major.minor.tiny @ 6b3acf1 🙃

koic added a commit to koic/oracle-enhanced that referenced this pull request Feb 18, 2018

Rails 6 requires Ruby 2.4.1+
Refer rails/rails#32034, rails/rails@6b3acf1.

And Rails 6 will require Ruby 2.4.1 or higher. Since JRuby 9.1.15.0 is
equivalent to MRI 2.3.3, it does not meet the requirements of Rails 6.
https://travis-ci.org/rsim/oracle-enhanced/jobs/342878700#L928-L929

This commit drop JRuby 9.1.15.0.

@yahonda yahonda referenced this pull request Feb 20, 2018

Closed

CI against jruby-head #1720

yahonda added a commit to yahonda/rails that referenced this pull request Feb 21, 2018

CI with `jruby-head` compatible with Ruby 2.4.1
Since rails#32034 Rails 6 requires Ruby 2.4.1 or higher.
Two CI jobs configured with the latest version of`jruby-9.1.15.0`
compatibile with Ruby 2.3.3 are getting errors:

https://travis-ci.org/rails/rails/jobs/343519339

```
Bundler could not find compatible versions for gem "ruby":
  In Gemfile:
    ruby java
    rails java was resolved to 6.0.0.alpha, which depends on
      ruby (>= 2.4.1) java
Could not find gem 'ruby (>= 2.4.1)', which is required by gem 'rails', in any
of the relevant sources:
```

kamipo added a commit to kamipo/rails that referenced this pull request Feb 25, 2018

kamipo added a commit that referenced this pull request Feb 25, 2018

bogdanvlviv added a commit to bogdanvlviv/rails that referenced this pull request Mar 3, 2018

Deprecate "active_support/core_ext/numeric/inquiry"
Numeric#positive? and Numeric#negative? was added to Ruby since 2.3,
see https://github.com/ruby/ruby/blob/ruby_2_3/NEWS
Rails 6 requires Ruby 2.4.1+ since rails#32034

jeremy added a commit that referenced this pull request Mar 3, 2018

Deprecate "active_support/core_ext/numeric/inquiry"
Numeric#positive? and Numeric#negative? was added to Ruby since 2.3,
see https://github.com/ruby/ruby/blob/ruby_2_3/NEWS
Rails 6 requires Ruby 2.4.1+ since #32034

kamipo added a commit that referenced this pull request May 6, 2018

@mperham

This comment has been minimized.

Show comment
Hide comment
@mperham

mperham May 12, 2018

Contributor

Out of curiousity, why not jump all the way to Ruby 2.5?

Contributor

mperham commented May 12, 2018

Out of curiousity, why not jump all the way to Ruby 2.5?

@matthewd

This comment has been minimized.

Show comment
Hide comment
@matthewd

matthewd May 12, 2018

Member

Mostly just because requiring a Ruby that's under a year old makes life difficult for people using OS packages.

Admittedly, we discussed it back in November, and there was a fair time before the final release... might be worth revisiting when we get to beta.

Member

matthewd commented May 12, 2018

Mostly just because requiring a Ruby that's under a year old makes life difficult for people using OS packages.

Admittedly, we discussed it back in November, and there was a fair time before the final release... might be worth revisiting when we get to beta.

@mperham

This comment has been minimized.

Show comment
Hide comment
@mperham

mperham May 12, 2018

Contributor

Seems reasonable. One data point: I noticed Ubuntu 18.04 ships Ruby 2.5.1. 💯

Contributor

mperham commented May 12, 2018

Seems reasonable. One data point: I noticed Ubuntu 18.04 ships Ruby 2.5.1. 💯

kamipo added a commit that referenced this pull request Jul 29, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment