Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Require Ruby 2.5 for Rails 6. #34754

Merged
merged 1 commit into from Dec 19, 2018
Merged

Require Ruby 2.5 for Rails 6. #34754

merged 1 commit into from Dec 19, 2018

Conversation

@kaspth
Copy link
Member

@kaspth kaspth commented Dec 19, 2018

Generally followed the pattern for #32034

  • Removes needless CI configs for 2.4
  • Targets 2.5 in rubocop
  • Updates existing CHANGELOG entries for fewer merge conflicts
  • Removes Hash#slice extension as that's inlined on Ruby 2.5.
  • Removes the need for send on define_method in MethodCallAssertions.

cc @jeremy @matthewd @dhh

Generally followed the pattern for #32034

* Removes needless CI configs for 2.4
* Targets 2.5 in rubocop
* Updates existing CHANGELOG entries for fewer merge conflicts
* Removes Hash#slice extension as that's inlined on Ruby 2.5.
* Removes the need for send on define_method in MethodCallAssertions.
@kaspth
Copy link
Member Author

@kaspth kaspth commented Dec 19, 2018

Well, that's helpful rails-bot 😂@gmcgibbon are you up for tuning the auto-labeling?

jeremy
jeremy approved these changes Dec 19, 2018
Copy link
Member

@jeremy jeremy left a comment

Relaying from @matthewd, who noted that Ruby 2.5 will be over a year old at Rails 6 release, aligning neatly with our "oldest fully-maintained version at release time" Ruby version plan.

@kaspth kaspth merged commit 04159a7 into master Dec 19, 2018
3 checks passed
@kaspth kaspth deleted the require-ruby-2.5 branch Dec 19, 2018
bogdanvlviv added a commit to bogdanvlviv/rails that referenced this issue Dec 20, 2018
Since rails#34754 Rails 6.0 requires Ruby 2.5+
@bogdanvlviv bogdanvlviv mentioned this pull request Dec 20, 2018
bogdanvlviv added a commit to bogdanvlviv/rails that referenced this issue Dec 20, 2018
- Fix a few deprecation warnings
- Remove testing of `Hash#slice`
- Imporve test of `Hash#slice!`
- Remove mention about `Hash#slice` from the guide
bogdanvlviv added a commit to bogdanvlviv/actiontext that referenced this issue Dec 20, 2018
Rails 6 requires Ruby 2.5+ or newer.
See rails/rails#34754.
@007lva 007lva mentioned this pull request Dec 23, 2018
4 tasks
pixeltrix added a commit to pixeltrix/rspec-rails that referenced this issue Jan 24, 2019
Rails 6.0 will require Ruby >= 2.5.0 - see rails/rails#34754.
penelopezone pushed a commit to rspec/rspec-rails that referenced this issue Jan 24, 2019
benoittgt added a commit to benoittgt/rspec-rails that referenced this issue Feb 22, 2019
benoittgt added a commit to rspec/rspec-rails that referenced this issue Feb 23, 2019
penelopezone pushed a commit to rspec/rspec-rails that referenced this issue Apr 20, 2019
benoittgt added a commit to rspec/rspec-rails that referenced this issue May 1, 2019
penelopezone pushed a commit to rspec/rspec-rails that referenced this issue Jun 12, 2019
benoittgt added a commit to rspec/rspec-rails that referenced this issue Aug 21, 2019
benoittgt added a commit to benoittgt/rspec-rails that referenced this issue Aug 24, 2019
yahonda added a commit to yahonda/lograge that referenced this issue Sep 4, 2019
* Rails 6.0 requires Ruby 2.5
rails/rails#34754

* "JRuby 9.2.x is compatible with Ruby 2.5.x"
https://www.jruby.org/2019/04/09/jruby-9-2-7-0.html
yahonda added a commit to yahonda/lograge that referenced this issue Sep 4, 2019
* Exclude CI matrix between Ruby 2.6 and Rails 6.0
Rails 6.0 requires Ruby 2.5
  - rails/rails#34754

No need to exclude any JRuby because "JRuby 9.2.x is compatible with Ruby 2.5.x"
  - https://www.jruby.org/2019/04/09/jruby-9-2-7-0.html
yahonda added a commit to yahonda/lograge that referenced this issue Sep 4, 2019
Exclude CI matrix between Ruby 2.6 and Rails 6.0
* Rails 6.0 requires Ruby 2.5
  - rails/rails#34754

* No need to exclude any JRuby because "JRuby 9.2.x is compatible with Ruby 2.5.x"
  - https://www.jruby.org/2019/04/09/jruby-9-2-7-0.html
yahonda added a commit to yahonda/lograge that referenced this issue Sep 4, 2019
Exclude CI matrix between Ruby 2.6 and Rails 6.0
* Rails 6.0 requires Ruby 2.5
  - rails/rails#34754

* No need to exclude any JRuby because "JRuby 9.2.x is compatible with Ruby 2.5.x"
  - https://www.jruby.org/2019/04/09/jruby-9-2-7-0.html
sinsoku added a commit to sinsoku/sorcery that referenced this issue May 10, 2020
Rails 6 does't support Ruby 2.4.
ref: rails/rails#34754
athix pushed a commit to Sorcery/sorcery that referenced this issue Jun 16, 2020
* Cache bundler on Travis

* Add support for Rails 6

Since the usage of `MigrationContext` was changed in rails/rails#36439,
adds a branch to MigrationHelper.

We are loading 'rails/all' in our test code, it implicitly load action_text from Rails 6.
ActionText requires ApplicationController, adds it.
ref: https://github.com/rails/rails/blob/v6.0.3/actiontext/lib/action_text/engine.rb#L50

* Exclude Ruby 2.4 for Rails 6

Rails 6 does't support Ruby 2.4.
ref: rails/rails#34754
yahonda added a commit to yahonda/activerecord-tidb-adapter that referenced this issue Sep 8, 2021
Similar pull request as pingcap#21, this pull request bumps
the required ruby version to Ruby 2.5 for 6-1-stable branch.

Refer rails/rails#34754
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

2 participants