Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Circular require fix #53

Closed
wants to merge 1 commit into from

2 participants

@krekoten

No description provided.

@jeremy
Owner

These are intentionally circular requires, so you can require 'active_record/railtie' directly. So the warning is safe to ignore.

@claudiob claudiob referenced this pull request from a commit in claudiob/rails
@zzak zzak The --format option must come first to allow loading of the extra
options. Fixes #42 #53

Patch by @benfyvie, confirmed by @drbrain
See voloko/sdoc#53 (comment)
e1e1c3d
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
This page is out of date. Refresh to see the latest.
View
1  actionmailer/lib/action_mailer/railtie.rb
@@ -1,5 +1,4 @@
require "action_mailer"
-require "rails"
require "abstract_controller/railties/routes_helpers"
module ActionMailer
View
1  actionpack/lib/action_controller/railtie.rb
@@ -1,4 +1,3 @@
-require "rails"
require "action_controller"
require "action_dispatch/railtie"
require "action_view/railtie"
View
1  actionpack/lib/action_dispatch/railtie.rb
@@ -1,5 +1,4 @@
require "action_dispatch"
-require "rails"
module ActionDispatch
class Railtie < Rails::Railtie
View
1  actionpack/lib/action_view/railtie.rb
@@ -1,5 +1,4 @@
require "action_view"
-require "rails"
module ActionView
# = Action View Railtie
View
3  activemodel/lib/active_model/railtie.rb
@@ -1,2 +1 @@
-require "active_model"
-require "rails"
+require "active_model"
View
1  activerecord/lib/active_record/railtie.rb
@@ -1,5 +1,4 @@
require "active_record"
-require "rails"
require "active_model/railtie"
# For now, action_controller must always be present with
View
1  activeresource/lib/active_resource/railtie.rb
@@ -1,5 +1,4 @@
require "active_resource"
-require "rails"
module ActiveResource
class Railtie < Rails::Railtie
View
1  activesupport/lib/active_support/i18n_railtie.rb
@@ -1,5 +1,4 @@
require "active_support"
-require "rails"
require "active_support/file_update_checker"
require "active_support/core_ext/array/wrap"
View
1  activesupport/lib/active_support/railtie.rb
@@ -1,5 +1,4 @@
require "active_support"
-require "rails"
require "active_support/i18n_railtie"
module ActiveSupport
Something went wrong with that request. Please try again.